SP-20 drive chain issue

The chain on my SP-20 seems to be getting hung up or caught on something. In the 15-second video above, you can see it catch in the beginning and then towards the end. Is one of the gears failing? I need to run several jobs this week but don’t want to risk snapping the chain.

I added a second video here. The chain is now clattering and will barely drive the main roller. When I engage the other rollers, it doesn’t have enough strength to drive the full ink train. Now I have to figure out how to clean the press up.

I’m desperate here for a press mechanic in the NY/NJ area who can come look at this today or tomorrow. Perry Tymeson, whom I usually use, is out of town for a week.

IMG_9013

IMG_9015

SP-20 drive chain issue

8 thoughts on “SP-20 drive chain issue

  • June 2, 2015 at 4:52 pm
    Permalink

    Fixed! I loosened both set screws all the way. The sprocket only moved very slightly, but, after tightening the set screws again, the chain moved freely with no rattling. And, the ink drum activates the other rollers. I think I’m back in business. Vanderblog to the rescue! Thanks everyone!

  • June 2, 2015 at 4:07 pm
    Permalink

    Tighten both set screws on the sprocket, but move the sprocket first away from the side of the press. Loosen both set screws, the sprocket should move, then retighten both set screws. Check the ink drum springs on both ends of the ink drum to make sure one or both are not broken as that often happens. I don’t think the chain is part of the problem–chain under tension will pull it straight and it’s too close to the side of the press. The sprocket, with one set screw, may actually be turning on the shaft and under tension, or load, may be the problem.

  • June 2, 2015 at 3:32 pm
    Permalink

    I added two more photos to the original post, one showing the rubbing of the chain against the side of the machine. The second is, I gather, the set screw on the gear collar attached to the motor. There are two set screws, though. Does it matter which one I adjust? I tightened one of them but it made it harder to turn the ink drum. Should I be loosening it?

  • June 2, 2015 at 1:34 pm
    Permalink

    How do I tighten the sprocket if that’s the issue? I’m not sure how to get access to it.

    The chain is definitely rubbing along the sheet metal edge. I stuck a piece of paper behind it and the sound changed, so that’s definitely part of the problem.

  • June 2, 2015 at 1:29 pm
    Permalink

    In the first video it looks as if the chain is intermittently rubbing against the washup unit, perhaps at the master link. It the second video it sounds like the sprocket is not turning as fast as the chain, indicating that it is loose on the shaft.

  • June 2, 2015 at 1:09 pm
    Permalink

    The second video would indicate that the chain has changed position, and is rubbing more or less constantly on the sheet metal edge of the housing. Check to see that the sprocket hasn’t come loose form the shaft of the gear reducer or the other end has come loose and is making the chain rub. If the sprocket wheels are not loose, check the motor mounts to make certain they arte not loose and moving around.

    John Henry

  • June 2, 2015 at 9:57 am
    Permalink

    The thunk in the video is followed by something different in the chain sequence, maybe the connecting link. Examine the chain, look for a loose keeper or some junk in the link. If it were the gear it would be more frequent.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.