Challenge 21MP Vibrator Assembly Issues

Hi Folks –

I know that I use one of the “knock offs”, a Challenge 21MP (similar to the Vandy SP15), but I’m up poop creek without a plunger. I am calling on the collective wisdom of this group….

I’ve been restoring this press (some rust – lots of gunk) and have run into a problem with the Vibrator Assembly. It is in good shape visually but will not oscilate when the press is running. it moves to the far end of the bar and stays – it doesn’t return.

I’ve looked at the parts list breakdown and can’t find anything I might be missing. Ideas?

Brent

3 thoughts on “Challenge 21MP Vibrator Assembly Issues

  1. Brent Done - November 28, 2008

    Thanks guys…I’ll take it apart and see what that little crescent is up to…

    Brent

  2. Paul Moxon, Moderator - November 28, 2008

    Just like Vandercooks the worm crescent is inside the vibrator tube. To remove it locate the crescent holder screw on the face of the oscillating tube. Because dried ink has probably filled in the slotted head it will appear as a black dot.

  3. JoDee Stringham - November 28, 2008

    Brent,
    I recently had a similar problem. Is the crescent part in good shape and installed correctly? Also, you might check the set screw to make sure it’s allowing the crescent to rotate at the end of the turn. This is assuming that yours is a double-action vibrator. If it’s single-action I’ve got nothin’. Good luck!

    JoDee

Leave a Reply

Copyright © 2022 vandercookpress.infoTheme by SiteOrigin
Scroll to top